2008. 4. 28. 00:36
     

 PSP의 비디오 모드를 뒤지다 보니, 4BYTE RGB를 사용하는 FrameBuffer모드가 기본인 것 같았습니다. DebugPrint류의 함수를 곰곰히 살펴본 결과 U32의 값으로 비디오 주소에 계속 출력하고 있더군요. 이걸로 바로 확신이 섰습니다. ^0^)/~

 그래서 NDS에 만들어뒀던 한글 출력 라이브러리를 포팅할려고, 뚝딱 소스를 갖다 부었더니 뭔가 잘 안되더군요. ㅜ_ㅜ)/~ 한글이 출력되는 게 아니라 뭔 점같은게 출력됬습니다. 한참 소스를 뒤진 결과, 간단한 연산 버그가 있어서 그랬습니다. 교육 때 들었던 unsigned char과 int의 연산 문제를 제 소스에서 딱 마주치니 웃음이 실실... ㅜ_ㅜ...

 결국 그 문제를 해결하고 나니 화면에 한글이 나왔습니다. ㅜ_ㅜ)-b 아아~ 이 감명깊은 순간을 캡쳐로 저장했어야하는데 RemoteJoy라는 프로그램을 깔지 않아서.... 내일 집에 오는대로 RemoteJoy를 설치해서 캡쳐해 올리겠습니다. 물론 소스와 함께 말이지요 >ㅁ<)/~!!!

 그럼 다들 좋은밤 되세요 ^^)/~~



Android App

Posted by 호기심 많은 kkamagui(까마귀, 한승훈)

댓글을 달아 주세요

  1. Favicon of http://www.debianusers.org BlogIcon 태용 2008.04.28 08:58  댓글주소  수정/삭제  댓글쓰기

    -_-a 역시. 늪이군요... 부럽...

    • Favicon of http://kkamagui.tistory.com BlogIcon kkamagui 2008.04.28 21:38  댓글주소  수정/삭제

      태용님 ㅎㅎ 늪이긴한데, 뭔가 좀 얕은 늪이랄까요?

      잘만들어진 커널이 있으니, 오히려 NDS 보다는 개발의욕이 떨어지는 것 같습니다. ㅜ_ㅜ)/~

  2. Favicon of http://www.hizstory.net BlogIcon 마로 2008.04.28 09:53  댓글주소  수정/삭제  댓글쓰기

    우와.. ㅠㅠ 재밌으시겠어요~
    저도 좀 따라 해야 되는데 ㅋ_ㅋ)

  3. SeHwa 2008.04.28 14:18  댓글주소  수정/삭제  댓글쓰기

    어렵네요 =ㅅ= 으흠
    PSP에 한글출력하는 소스코드를 어디서 본것 같은데
    아마 어떤분이 샘플(?) 로 올려놓은것같은데

    아 그런데 한글 폰트는 기본내장인가요?

    • Favicon of http://kkamagui.tistory.com BlogIcon kkamagui 2008.04.28 21:42  댓글주소  수정/삭제

      PSP의 flash0에 폰트 파일이 있습니다만, 어떻게 구성되있는지를 몰라서 자체적으로 생성한 폰트로 출력합니다. ^^

      한글 출력을 이미 어떤 분이 해놓으셨나보네요. ;)

      나중에 한번 찾아봐야겠습니다. ㅎㅎ

  4. 개발시작 2008.04.28 22:37  댓글주소  수정/삭제  댓글쓰기

    난 언제 해보나. ㅠㅠ 컴파일도 못하고 있으니 --;
    뒤늦은 나의 실현을 위해 도전 고고 ~ -0-
    많이 도와주세요 ^^;

    • Favicon of http://kkamagui.tistory.com BlogIcon kkamagui 2008.04.29 23:56  댓글주소  수정/삭제

      헉... 아직도 안되시나요 ㅜ_ㅜ)/~
      DevkitPro를 완전히 지우시고 실행파일들이 있는 경로를 Path에 새로 추가해보시는 것이 좋을 것 같습니다.
      DevkitPro만 설치하면 별 문제없이 실행 되야하는데... 잘 안되는 경우도 있나 보네요 ^^;;;;

  5. SeHwa 2008.04.30 13:12  댓글주소  수정/삭제  댓글쓰기

    DevkitPro 는 저도 이상하게 안되더군요 -ㅅ-;;
    그래서 그냥 Cygwin + psptoolchain 설치해서 사용하고 있어요~
    (대신 이거 설치하는 시간이 몇시간 걸렸다는 ..)

    • Favicon of http://kkamagui.tistory.com BlogIcon kkamagui 2008.04.30 22:41  댓글주소  수정/삭제

      헛~ 그렇군요. ^^;;; 혹시 The Application 어쩌구 하는 에러가 발생하셨나요?
      저도 그 문제로 고민하다가 결국 command.exe를 실행하는 신공을 발휘해서 해결했답니다. ㅜ_ㅜ...
      아아... 정말 너무 어려워요 ㅎㅎ